最新 追記

ポケットを空にして。

1985|10|
2004|01|02|03|04|05|06|07|08|09|10|11|12|
2005|01|02|03|04|05|06|07|08|09|10|11|12|
2006|01|02|03|04|05|06|07|08|09|10|11|12|
2007|01|02|03|04|05|06|07|08|09|10|11|12|
2008|01|02|03|04|05|06|07|08|09|10|11|12|
2009|01|02|03|04|05|06|07|08|09|10|11|12|
2010|01|02|03|04|05|06|07|08|09|10|11|12|
2011|01|02|03|04|05|06|07|08|09|10|11|12|
2012|01|02|03|04|05|06|07|08|09|10|11|12|
2013|01|02|03|04|05|06|07|08|09|10|11|12|
2014|01|02|03|04|05|06|07|08|09|10|11|12|
2100|01|

「人の心に残るというのが大事」と言う話。

何か連絡がある場合はメールでどうぞ(過去の日記へのツッコミは基本的にみていません)
プレゼントは随時受け付けております :-) ここ最近のツッコミ/トラックバックリスト。


2014-04-10 [長年日記] この日を編集

--compress-strategy=extremeで怒られる

dpkg-source: info: using options from fonts-horai-umefont-461/debian/source/options: --compression=xz --compression-level=9 --compress-strategy=extreme
dpkg-source: warning: --compress-strategy=extreme is not a valid option for Dpkg::Source::Package::V3::Quilt

このオプション指定ができない? man dpkg-deb では表記があるんだけど

       -Scompress-strategy
              Specify  which  compression  strategy  to  use  on the compressor backend,
              when building a package (since dpkg 1.16.2). Allowed values are none (since 
              dpkg 1.16.4), filtered, huffman, rle and fixed for gzip (since dpkg 1.17.0)
              and extreme for xz.

2014-04-18 [長年日記] この日を編集

ruby-script-but-no-ruby-dep で少しだけ悩んだ

rubyなパッケージでlintian error "ruby-script-but-no-ruby-dep" がでて、?となった。原因はわかってみればなんてことはない。

XS-Ruby-Versions: ruby2.0
(snip)
XB-Ruby-Versions: ${ruby:Versions}

としていたら

Depends: ruby2.0

になっていない上記のエラーになる。まぁそりゃそうか。ruby と指定していて2.1とかでこけたら駄目だし、ね。しかし、このlintian tagの説明ではそのことがわかりづらい。

If a script in the package uses #!/usr/bin/ruby, the package needs a dependency on "ruby | ruby-interpreter". 
This allows users to choose which interpreter to use by default.
If the package is intended to be used with a specific Ruby version, its scripts should use that version directly, such as #!/usr/bin/ruby1.8
 
If a script uses #!/usr/bin/ruby1.9, then the package needs a dependency on "ruby1.9".

2014-04-27 [長年日記] この日を編集

変更を突っ込んだら問題が見つかってその対処

net-snmpはまだまだ色々修正点が多そう。手がかかるね…

といって、何も変更しないとversion jumpした時に確認漏れが多数出るし。

libsemanageとlibselinuxが共にruby bindingでgem2debがruby1.9.1をdropしたのにハマってた

debian/rulesに色々書くのではなく、別のdebian/ruby.mkというファイルに分離していたが、こういうのを作ってincludeするスタイルにするほうがスマートなんだろうか。いちいちバージョンのアップのために変更して回るのは辛いのは辛い。

三本柱作戦とかどうか。

  • いつものバグつぶし
  • hundred papercuts
  • てこの原理が効きそうなもの?